Can Studios Home

Importing existing courses

You can import courses previously created in the Adapt framework/ compatible third party tools, or courses exported from your own offline backup, with these steps.

Use Cases

The import function for adapt will allow you to import courses:

  • built in the Adapt Learning framework
  • exported from your system for offline backup
  • from open source compatible third party tools.

From October 2019 the Adapt from Can Studios authoring tool allows you to import courses from older Adapt framework versions; the authoring tool will update these to the current framework your tool uses.

(Note that each Adapt authoring tool instance can only be connected to (ie building in) a single version of the framework. Find out more about cross-framework migration.)

The import process will sort the plugins used in the course into categories. An import details screen will explain whether the course can be imported, and the status of its plugins.

Requirements for import

You must be an administrator user (contact us if you are unsure).
You must be using the system in advanced mode (check at the top of the screen).
Note: The file to be imported must be a Zip file containing the Adapt framework source (this is not the same as a SCORM zip file).

Steps to import a course

1) Ensure the authoring tool is advanced mode, using the switch at the top of the screen.

2) From the dashboard click “Import source”.
Adapt import button in situ

3) Select a file to import from your hard drive. You can import courses made directly in the Adapt framework or files exported from the authoring tool.
NB You must import source files, not compiled SCORM courses.
Adapt Authoring Tool Import Select File
Tip: The file structure inside the zip should look like this:

4) Click import

The authoring tool will examine each plugin used in the course for compatibility. It uses a traffic light system to tell you whether that plugin is supported in the authoring tool you are using, and consequently whether the import is possible.

Adapt authoring tool cross-framework import report showing plugins rated amber and green.

The categories are:

White – These plugins, as used in the course, match the version used in the authoring tool so there’s no problem. They won’t even appear on the import details screen.

Green (install) – Your current authoring tool doesn’t have this plugin installed, but the version of the plugin used in the course is compatible. The plugin will be installed into your authoring tool from the course.

Green (update) – Your current authoring tool has a version of this plugin installed already, but the version of the plugin used in the course is newer. Your current authoring tool will be updated to use the newer plugin version from the course.

Amber – The version of these plugins in your course are either not compatible with this authoring tool, or a newer version is already installed. The imported course will use the authoring tools existing version. You should test your course once imported.

Red – These plugins are not supported in this authoring tool. You must remove or update these plugins before you can continue with the import.

So long as your course doesn’t have any red-rated plugins you will be able to import it; the imported course will now use the version of framework that your authoring tool runs on.

Red plugins mean that the import gets blocked – these must be updated or removed from the course. You can edit the course in an authoring tool that uses the framework the course was built with to update or remove plugins. Alternatively, you can update plugins on a stand alone basis and install these into your V4 authoring tool. When you try to import your course, the import process will automatically swap out the old version of the plugin for the new one and you will be able to import the course.

The tool will upload the zip file, extract the contents and begin processing, this will add the course to the current users dashboard, and add all the assets from the course to the asset manager (for all users).

Trouble Shooting

By far the most common issue is users trying to import a SCORM zip file instead of Adapt Framework  source.

Trying to import a zip file of the wrong kind will give an error message : “Encountered an unexpected file structure. Please check you have uploaded a valid export package and try again.”

If you wish to move a course from one authoring tool to another then you will need to use the “Export source” option not “Download” (which builds the course for learner delivery).

To get the source file:

  • open the course (in advanced mode)
  • use the “Export source” button in the left hand menu.
  • You’ll only have this option if you are an administrator. Neither course creators nor authenticated users can download source files.

Limitations

The Adapt authoring tool will change the internal IDs of all content during the import (as it does when copying). This means any hard coded links or CSS relying on these IDs will need to be updated after import. It is currently advised that you avoid making reference to IDs to allow easier management of courses.

When importing a course from another authoring tool, any project specific CSS will need to be manually added (this is a single copy and paste action) as the CSS is not currently exported with the course.